読者です 読者をやめる 読者になる 読者になる

Xcodeバージョン指定をしながらxcodebuildコマンドを使う方法

Xcodeを 複数入れている時にxcodebuildコマンドでビルドする時の話です。 自分がデフォルトで使っているバージョンを調べます。

$ xcodebuild -version
Xcode 5.0.2
Build version 5A3005

これはxcode-selectで指定された値です。 (man xcode-select Usageの節参照)

そこで、xcodebuildコマンドで利用したいXcodeの指定方法は2つあります。

  1. xcode-selectで指定する

    • ただし、superuser権限が必要。システム上の全ユーザーに影響を与える。
  2. DEVELOPER_DIRで指定する

1の方法を使うと、今後もそのXcodeをdeveloper directoryとして使うことになります。 一時的に、使うXcodeのバージョンを変えたいときはDEVELOPER_DIRを使いましょう。

(man xcode-select のEnvironmentの節参照)

実行例

$ xcodebuild -version
Xcode 5.0.2
Build version 5A3005
$ DEVELOPER_DIR=~/src/xcode/Xcode_4-6-1.app/ xcodebuild -version
Xcode 4.6.1
Build version 4H512

https://developer.apple.com/library/mac/documentation/Darwin/Reference/ManPages/man1/xcode-select.1.html